Cannot mount NAS

Raspberry Pi related support

Cannot mount NAS

Postby foxint » 08 Jan 2019, 09:49

Hi Guys,

Thanks for all the help. I am temporarily having a break from the HiFiBerry Dac + Pro XLR as nothing works.. I did email HiFiBerry, but they sent me back here....so rock and a hard place??? Perhaps I should sell it and get another with XLR

I have been able to hear the radio on my other pi the Pi2Media 502 DAC (not that keen on this one as it does not have XLR).

I have never heard any of my flac files as I have never been able to mount the NAS. It is all about the music...ha-ha

Can anyone lend a hand???

I have mount error(112): host is down. Refer to the mount.cifs(8) manual page. I searched this on the site and got nothing. I pushed all the buttons "Update MPD Library" Rebuild MPD Library" "remount all Sources". Nothing

The flac files are on a PC win 10 via a router on another PC on a separate HDD.

Any suggestions?
foxint
 
Posts: 181
Joined: 29 Mar 2016, 06:36

Re: Cannot mount NAS

Postby eea123 » 08 Jan 2019, 12:13

It doesn't sound like you have the drive pathed to Rune under "Sources". I have my "Network Mount" mounted via its IP address, //10.0.0.XX/multimedia/music. I'll offer that I gave the Rune app admin rights instead of fighting to setup an individual account.

If you are using WiFi, make sure both are connected via the same router or use physical ethernet connections. I have an old NetGear router that I use to cover the outside deck and for some reason it assigns 192.168.0.XX even though the primary XFinity's DCHP is assigning 10.0.0.XX. If I use the Rune app on my tablet connected to the 192 subnet I am out of luck connecting to the player which is hardwired to the Comcast router in the 10 subnet.
eea123
 
Posts: 43
Joined: 23 Dec 2017, 19:19

Re: Cannot mount NAS

Postby foxint » 08 Jan 2019, 21:18

Hi Mate

Thanks for the reply.

I am using ethernet - wire. I have the IP address - 192.168.X.X/W/Music. Everything has a static IP Address including the Pi.

MediaMonkey can find the music at this IP Address - so I am very confused that the Pi cannot find it????

I am using PC Win 10. No tablets or phones or anything like that

???
foxint
 
Posts: 181
Joined: 29 Mar 2016, 06:36

Re: Cannot mount NAS

Postby cmh714 » 08 Jan 2019, 22:23

So on my Western Digital NAS, The Volume Name is Public with the "Shared Music" folder under it. On the WD interface it says my nfs mount point is: 192.168.1.111/nfs/Public

notice I did not put in the nfs before the Public but its there and thats what works for me when I mount.....without the nfs/ before Public it fails.

You may have something similar like that.....GL!
cmh714
 
Posts: 330
Joined: 04 May 2014, 03:06

Re: Cannot mount NAS

Postby foxint » 08 Jan 2019, 22:34

Hi Mate

Thank you.

My "NAS" is a PC that has 6 HDD that I use to backup my other 6 HDD. Since my main PC is not shared (I have kids and would not like them to make changes by accident), I have shared ALL the drives on the other PC. As I said the MediaMonkey can play music from anywhere in the network

I added each and both suggestions - Nothing

Sorry for having such a strange arrangement. Perhaps something somewhere else. Perhaps this is future upgrade???
foxint
 
Posts: 181
Joined: 29 Mar 2016, 06:36

Re: Cannot mount NAS

Postby foxint » 09 Jan 2019, 07:58

Mate - I hope it is helpful...ha-ha
foxint
 
Posts: 181
Joined: 29 Mar 2016, 06:36

Re: Cannot mount NAS

Postby eea123 » 14 Jan 2019, 12:19

Here are my Source settings for Rune regarding my NAS:

Source Name: your-NAS-name-here
Fileshare protocol: SMB/CIFS
IP address: 10.0.0.XX
Remote directory: Multimedia/Music (again this will change for your NAS)
Guest access: OFF
Username: admin (I should probably change this someday)
Password: XXXXXX
Advanced options: left these as default

I'd say at this point you should check the multimedia settings on the NAS. For mine I think I had to make sure I added SMB protocol enabled for the sharing. My QNAP media streaming app is showing my RuneAudio's IP as connected, but I think it has more to do with this showing up under mapping. I also have it mapped under Windows as Y: drive for \\10.0.0.XX\Multimedia\Music.
eea123
 
Posts: 43
Joined: 23 Dec 2017, 19:19

Re: Cannot mount NAS

Postby englishtim » 14 Jan 2019, 13:06

Hi Everyone,

eea123's comment about SMB reminded me of some mount-related struggles I had a while back with the "official" build on my first-gen Pi Model B...

It seems that RuneAudio can in some circumstances be quite sensitive to the version of SMB that's used to communicate with the NAS - if the SMB version on the NAS is "too new" it borks the communication to the Pi. When I first hit this problem on the official v0.3 build my Pi needed to use SMB 1 - my NAS at the time was set to use SMB 3. Downgrading the SMB version on the NAS fixed the problem. Later builds (for instance Gearhead & Janui's excellent v0.5 beta) are less fussy, and in my experience can tolerate at least SMB 2.

As the OP mentioned that their NAS is PC-based there's a possibility that SMB 1 is disabled - I vaguely recall that Windows does this by default.

Hope this helps,

Peace and friendship,
englishtim
  • Raspberry Pi 3 Model B+ > Behringer U-Control UCA202 >
      Denon RCD-M38DAB > DIY KEF Cresta II / Caprice I
      Pro-Ject Head Box S > Sennheiser HD 650
  • Raspberry Pi 3 Model B > FiiO E10K > Sansui AU-317 > Celestion SL6;
User avatar
englishtim
 
Posts: 28
Joined: 20 Feb 2015, 11:36
Location: Proud to be in Europe

Re: Cannot mount NAS

Postby foxint » 14 Jan 2019, 22:43

Guys – thank you.

I do have some questions, things I do not understand:

Eea123:
Make sure I added SMB protocol enabled for the sharing
• I have no idea what this means or how to do this?
• The NAS is an old PC and using it in the windows environment is easy.

Englishtim: Good point. But I have not knowledge of SMB as it relates to windows.


Source Name: your-IP Address
File share protocol: SMB/CIFS
IP address: IP Address – as above
Remote directory: W/Music
Guest access: ON
Username: Greyed out
Password: Greyed out
Advanced options: left these as default


Question: “Log in with guest account NO use/password required”

But when I make the Guest Access OFF – it asks me for a username and password

How do I find out my username and password – I do not use this and no one uses this on the network. Yes, it is not “safe” but if I cannot trust the family who can I trust.

I still get - mount error(112): Host is down Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
foxint
 
Posts: 181
Joined: 29 Mar 2016, 06:36

Re: Cannot mount NAS

Postby eea123 » 15 Jan 2019, 12:12

I personally haven't done a PC based NAS, but:

https://www.windowscentral.com/how-access-files-network-devices-using-smbv1-windows-10

The article states Windows 10 no longer supports SMBv1, but has a work around.
Last edited by eea123 on 19 Jan 2019, 12:21, edited 1 time in total.
eea123
 
Posts: 43
Joined: 23 Dec 2017, 19:19

support RuneAudio Donate with PayPal

Next

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 3 guests