7" RPi touch display aspect ratio incorrect

Raspberry Pi related support

7" RPi touch display aspect ratio incorrect

Postby lmorhac » 31 Jan 2019, 03:09

Hello,

I have integrated RPi3, Hifiberry AMP2 and a 7” touchscreen display P/N: 899-7466 https://www.raspberrypi.org/products/raspberry-pi-touch-display/

I’m experiencing an issue with the local browser on the touchscreen displaying the two circular widgets for time status and volume control as elliptical shapes.
When I run the RuneUIe on my PC these widgets are perfect circles.

I have edited /boot/config.txt and tried several different settings but no luck correcting the ellipses into circles. This is what I’m at:
disable_overscan=1
framebuffer_width=800
framebuffer_height=480

Any clue as to what I’m doing wrong?

A follow up question:
The RuneUIe on my PC displays the playback controls on the top as a narrow strip and second strip on the bottom with library, Playback and Playlist buttons. The top and bottom strips are not displayed on the local browser (touchscreen). I presume this is an intended feature, a part of touch UI?

Many thanks,
Lubo
lmorhac
 
Posts: 1
Joined: 27 Jan 2019, 01:16

Re: 7" RPi touch display aspect ratio incorrect

Postby janui » 31 Jan 2019, 11:03

Hi morhac,
You did not specify which version of RuneAudio you are using.
You could try using V0.5b (download here: runeaudio-0-5-beta-for-all-raspberry-pi-models-t6532.html#p25819) and upgrade it to the latest patch level with git pull (see instructions in the post).
Then you can switch on the local browser in the Settings UI. After switching the local browser ON you can also adjust the zoom factor which should keep the aspect ratios correct. There should be no need to modify settings in /boot/config.txt
janui
User avatar
janui
 
Posts: 649
Joined: 20 Dec 2014, 12:55
Location: Ollanda

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 9 guests